ゆるく働き ゆるく生きる ゆるいだれかの日記

menu

ゆるりの足あと


Google Colaboratoryでmecabをインストールできない場合の対処法!

Google Colaboratoryでmecabを試そうと思いインストールしてみたので、その備忘録です。

を実行したら下記エラーが出てインストールできませんでした。

mecabをインストールできなかった原因

エラーが出た原因はmecab-ipadicがインストールされていないためでした。

そこで、インストールを試みます。

Google Colabはどうもubuntuで動いているのか、apt-getが使えるようです。
(yumとかbrewは使えませんでした。brew使えないのは当然ですか・・・)

mecabをインストールする方法

というわけで、mecab-ipadicを含めてapt-getでインストールしていきます!

そして、

を実行すれば

のようにmecabをインストールできました!

試しにimportしてみます。

インストールに失敗していればエラーが出ますが、何のエラーも出てこないのでmecabインストール成功です。

以上、 Google Colaboratoryでmecabをインストールできない場合の対処法! でした!

もし上記で解決しない場合は、teratailで質問すると解決の糸口が見つかるかもしれません。

ご不明な点があればコメント頂ければできる限り対応したいと思います!(たぶんteratailの方が早いし詳しいですが・・・)

Sponsored by

少しはお役に立てましたか?

役に立つかも?と思われた方はぜひシェアを!

関連記事

  1. この記事へのコメントはありません。

  1. この記事へのトラックバックはありません。

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

過去に作成したサイト集